National Center for Macromolecular Imaging

EMAN2

EMAN 2.04 - released on 11/17/11
This is a minor update of EMAN 2.03, including bug fixes and some feature enhancements

The EMAN2 binary and source downloads also include SPARX !

Please follow the installation instructions at:
http://blake.bcm.edu/emanwiki/EMAN2/Install

Documentation is provided through the EMAN2 Wiki



Windows users - Please note that while we do our best to periodically test the windows release to make sure it's still functioning, it is far less well-tested than the linux/Mac releases. Please report any problems you encounter.

Mac users, we do not support 10.5 since there are a number of issues with OS provided dependencies not working as they should.

Linux users - Linux x86 is for 32 bit Linux. Linux x86_64 is for 64 bit Linux. use command 'uname -i' to determine whether your Linux is 32 bit or 64 bit if you are not aware. The GCC4 binaries are new as of 4/2010, and provide a significant performance boost. It needs glibc version at least 2.5. You can check your system's glibc version by using command '/sbin/ldconfig -V'. Warning:We disabled the fftw cache for eman2.daily.linux64.tar.bz2 since it causes segfault on some size of image. That means it runs considerably slow compare to the gcc4 version. So please use the gcc4 version as long as your system supports.
NOTE: There was a fftw library issue with EMAN2 Linux binary release, which is fixed in current daily release. If you see segmentation fault in e2classaverage.py, please use daily release.


If you see following error message when your run EMAN2 GUI program, please remove the Qt libraries (rm -rf libQt*.so) from your EMAN2/lib directory:
"Cannot mix incompatible Qt library (version 0x407**) with this library. (version 0x40703)"

Version Changes

This version includes a substantial number of new features over the 2.03 release (though all have been available through the nightly snapshots). Major improvements include: